What's new

News Headlines

HowTo Tips Synology share files

How To
DC

DC

Admin
Staff member
Administrator
Moderator
V.I.P Member
Registered
LV
15
 
Joined
Jan 1, 2022
Messages
1,542
Reaction score
39
Points
4,065
Awards
3
Location
Doncaster
Cash
£0.00
Synology1

The following solution worked for me and I am now able to share files over the internet :

Open File Station, then go to Settings then open the Shared Links tab. Scroll down the menu, there is a Security title. There uncheck "Always open HTML files using plain text format" and check instead "Always use HTTPS via for sharing links via QuickConnect".

Of course QuickConnect must be enabled in Control Panel > QuickConnect
 
Last edited:
DC

DC

Admin
Staff member
Administrator
Moderator
V.I.P Member
Registered
LV
15
 
Joined
Jan 1, 2022
Messages
1,542
Reaction score
39
Points
4,065
Awards
3
Location
Doncaster
Cash
£0.00
Go to Control panel->External access->Advanced

where you will find options to fill the two (custom) ports - HTTP and HTTPS.

If you fill anything in these fields all shared links will have this custom port added after your domain - www.mydomain.com:5001/yoursharedfile... In this case the result will be "Sorry, the page you are looking for is not found."

If you don't fill the custom ports, leaving the fields empty, the default ports won't be added to your domain - www.mydomain.com/yoursharedfile... Now the shared links work again.

IMPORTANT: the port addon after the domain will appear automaticly even on previously shared files that worked in the past!

If you need to change the default ports (5000 and 5001) you should do it in Control panel->in tabs DSM or Application.
 
DC

DC

Admin
Staff member
Administrator
Moderator
V.I.P Member
Registered
LV
15
 
Joined
Jan 1, 2022
Messages
1,542
Reaction score
39
Points
4,065
Awards
3
Location
Doncaster
Cash
£0.00
How to add a folder to audiostation

add folder in file-station add music then do media indexing in control panel

now should be shown in AudioStation
 
Back
Top Bottom